Opened 16 years ago

Closed 14 years ago

#78 closed defect (worksforme)

deleting versions out of order results in inconsistency

Reported by: Dominic Hargreaves Owned by: Andrew Black
Priority: normal Milestone:
Component: openguides Version: 0.51
Severity: normal Keywords: moreinfo, hackfestsummer2007-reviewed
Cc:

Description

Just a quick one to remind me to look in more detail. If I delete version 2 out of 3 of a node, the comments end up being inconsistent. Bug in the delete function I guess.

Change History (6)

comment:1 Changed 15 years ago by Dominic Hargreaves

Keywords: moreinfo added

comment:2 Changed 14 years ago by Dominic Hargreaves

Owner: changed from Dominic Hargreaves to Nobody

comment:3 Changed 14 years ago by Kake

Keywords: hackfestsummer2007-reviewed added

Decision: we're agreed that being able to delete intermediate versions is a good thing (e.g. if someone makes a node, then a spammer hits it, then someone else edits the node to remove the spam but also adds good content of their own, we'll want to delete the middle version but leave the others alone).

So what needs doing is figuring out the issues this causes (Dom can't remember) and fixing them. Andrew will have a go at this.

comment:4 Changed 14 years ago by Kake

Owner: changed from Nobody to Andrew Black

comment:5 Changed 14 years ago by Andrew Black

Status: newassigned

comment:6 Changed 14 years ago by Andrew Black

Resolution: worksforme
Status: assignedclosed

Can't reproduce.

I have sucessufuly gone 123 -> 13 -> 1345 -> 135

Note: only administrators can delete historical versions.

  • (cur) (last) 16:53:52, 09 June 2007 Anonymous (version 5 - to keep) [delete]
  • (cur) (last) 16:43:48, 09 June 2007 Anonymous (version 3 - to keep) [delete]
  • (cur) (last) 16:43:16, 09 June 2007 Anonymous (version 1) [delete]
Note: See TracTickets for help on using tickets.