Opened 16 years ago

Closed 15 years ago

#3 closed defect (fixed)

International Characters in RSS feed.

Reported by: MRAMBERG@… Owned by:
Priority: normal Milestone:
Component: openguides Version:
Severity: normal Keywords: meetup
Cc:

Description

Sun May 23 16:30:11 2004 MRAMBERG - Ticket created [Reply] [Comment]

Subject: International Characters in RSS feed.

The RSS generator does not encode international characters, resulting in non-valid XML.

Download (untitled) 87b

Wed Jun 2 08:05:37 2004 EMARTIN - Correspondence added [Reply] [Comment]

From: Earle Martin

[MRAMBERG - Sun May 23 16:30:11 2004]:

The RSS generator does not encode international characters, resulting in non-valid XML.

This bug needs to rely on #6478.

Download (untitled) 168b

Mon Jun 21 13:57:02 2004 KAKE - Correspondence added [Reply] [Comment]

[MRAMBERG - Sun May 23 16:30:11 2004]:

The RSS generator does not encode international characters, resulting in non-valid XML.

Can you send me an example of some text that doesn't get encoded correctly, please? Or a URL where I can see for myself.

(kake@…)

Download (untitled) 272b

Thu Nov 18 07:52:21 2004 DOM - Ticket 6398 DependsOn? ticket 6478. Wed Dec 8 09:09:44 2004 guest - Correspondence added [Reply] [Comment]

[MRAMBERG - Sun May 23 16:30:11 2004]:

The RSS generator does not encode international characters, resulting

in non-valid XML.

The problem is not that the characters are wrong, but that the encoding for the RSS feed is set differently than the underlying content. If the encoding of the database is UTF-8, and the webserver is set to deliver a content-type of UTF-8, there will most likely not be any issues with this input/output.

Currently, RSS feeds are always created with an encoding of UTF-8, I'm going to track back the best way to modify that behavior for people who don't have the option of running utf-8 databases.

Download (untitled) 635b

Wed Dec 8 09:11:01 2004 DOM - Taken Wed Dec 8 09:11:07 2004 DOM - Status changed from new to open Mon Dec 13 19:23:04 2004 DOM - Severity Important changed to Normal

Change History (2)

comment:1 Changed 16 years ago by Dominic Hargreaves

Component: openguides

comment:2 Changed 15 years ago by nick

Keywords: meetup added
Resolution: fixed
Status: newclosed

The Wiki Toolkit feed stuff will now use the store's encoding, if no encoding was supplied.

OpenGuides now supplies the http_charset to the wiki toolkit feed stuff, if one's set. So, if you set a http_charset, it'll use that, otherwise use the store's encoding.

Note: See TracTickets for help on using tickets.