Opened 14 years ago

Closed 12 years ago

#244 closed defect (invalid)

install writes outside perl root

Reported by: mstevens Owned by: Nobody
Priority: normal Milestone:
Component: openguides Version: 0.61
Severity: normal Keywords:
Cc:

Description (last modified by Dominic Hargreaves)

I'm trying to install on a perl which is in /usr/local/perl-5.10.0/

Most of OpenGuides seems to go inside the root nicely, but I was disturbed to see it writing a bunch of stuff outside:

Installing scripts to /usr/lib/cgi-bin/openguides/:
Copying wiki.cgi -> /usr/lib/cgi-bin/openguides/wiki.cgi
Deleting /usr/lib/cgi-bin/openguides/wiki.cgi.bak
Trying to ensure that wiki.conf is protected by .htaccess.. apparent success. You should check that this is working!
Copying wiki.conf -> /usr/lib/cgi-bin/openguides/wiki.conf
Copying preferences.cgi -> /usr/lib/cgi-bin/openguides/preferences.cgi
Deleting /usr/lib/cgi-bin/openguides/preferences.cgi.bak
Copying search.cgi -> /usr/lib/cgi-bin/openguides/search.cgi
Deleting /usr/lib/cgi-bin/openguides/search.cgi.bak
Copying newpage.cgi -> /usr/lib/cgi-bin/openguides/newpage.cgi
Deleting /usr/lib/cgi-bin/openguides/newpage.cgi.bak
Installing templates to :
No 'to' or 'to_dir' parameter given to copy_if_modified at /usr/local/perl-5.10.0/lib/5.10.0/Module/Build/Base.pm line 4172.

Change History (3)

comment:1 Changed 14 years ago by Dominic Hargreaves

Description: modified (diff)

comment:2 Changed 14 years ago by Dominic Hargreaves

I can't really think of anything to say other than 'not a bug'. The installer is designed to work that way - it needs to install resources other than perl modules, so it pretty much has to do that. As I understand it, CPAN modules installing stuff in /usr/local/bin is fairly common - would installing to /usr/local/lib/cgi-bin be a more correct thing to do?

comment:3 Changed 12 years ago by Dominic Hargreaves

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.