Opened 14 years ago

Closed 13 years ago

#232 closed defect (worksforme)

Can't locate OpenGuides/Build.pm

Reported by: Dominic Hargreaves Owned by: Dominic Hargreaves
Priority: normal Milestone:
Component: openguides Version: 0.61
Severity: normal Keywords: cpanrt
Cc:

Description (last modified by Dominic Hargreaves)

ANDK <ANDK@…>: http://rt.cpan.org/Public/Bug/Display.html?id=27961

This happened with 0.61:

# running Build.PL
/home/src/perl/repoperls/installed-perls/perl/pFBiVrt/perl-5.8.0[...]31535/bin/perl
Build.PL

Beginning install process... if you already have an OpenGuides
configuration file and you don't want to have to type in all your config
parameters over again, abort this process now, copy that file to this
directory, and start again.

Continue with install? [y ]
y
No existing configuration file found; assuming this is a new install.
See the message above if this isn't correct.

Skip OpenGuides configuration? [n ]y
===========================================================================
Skipping OpenGuides configuration - any configuration options previously
saved will be used instead. You may tweak your configuration now by
editing the 'wiki.conf' file produced by this script.
===========================================================================
Checking whether your kit is complete...
Looks good

Checking prerequisites...
- ERROR: Wiki::Toolkit::Plugin::Categoriser is not installed
- ERROR: Wiki::Toolkit::Feed::Atom is not installed
- ERROR: Plucene is not installed
- ERROR: Wiki::Toolkit::Plugin::RSS::Reader is not installed
- ERROR: Wiki::Toolkit is not installed
- ERROR: Wiki::Toolkit::Plugin::Diff is not installed
- ERROR: Wiki::Toolkit::Plugin::Locator::Grid is not installed
- ERROR: Geography::NationalGrid is not installed
- ERROR: Wiki::Toolkit::Feed::RSS is not installed
- ERROR: Wiki::Toolkit::Formatter::UseMod is not installed
* Optional prerequisite Test::HTML::Content is not installed
* Optional prerequisite Wiki::Toolkit::Plugin::Ping is not installed
* Optional prerequisite Geo::HelmertTransform is not installed

ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the
versions
of the modules indicated above before proceeding with this installation

Creating new 'Build' script for 'OpenGuides' version '0.61'
Can't locate OpenGuides/Build.pm in @INC (@INC contains: _build/lib
/home/sand/.cpan/build/Net-SSH-Expect-0.06-45NXG0/blib/arch
/home/sand/.cpan/build/Net-SSH-Expect-0.06-45NXG0/blib/lib
/home/sand/.cpan/build/Acme-24-0.01-oHy9gA/blib/arch
/home/sand/.cpan/build/Acme-24-0.01-oHy9gA/blib/lib
/home/sand/.cpan/build/XML-RSSLite-0.11-gHYCUU/blib/arch
/home/sand/.cpan/build/XML-RSSLite-0.11-gHYCUU/blib/lib
/home/sand/.cpan/build/IO-Socket-SIPC-0.04-FedR0I/blib/arch
/home/sand/.cpan/build/IO-Socket-SIPC-0.04-FedR0I/blib/lib
/home/sand/.cpan/build/Tk-Wizard-2.011-nqTEOv/blib/arch
/home/sand/.cpan/build/Tk-Wizard-2.011-nqTEOv/blib/lib
/home/src/perl/repoperls/installed-perls/perl/pFBiVrt/perl-5.8.0[...]31535/lib/5.9.5/i686-linux-64int
/home/src/perl/repoperls/installed-perls/perl/pFBiVrt/perl-5.8.0[...]31535/lib/5.9.5
/home/src/perl/repoperls/installed-perls/perl/pFBiVrt/perl-5.8.0[...]31535/lib/site_perl/5.9.5/i686-linux-64int
/home/src/perl/repoperls/installed-perls/perl/pFBiVrt/perl-5.8.0[...]31535/lib/site_perl/5.9.5
.) at Makefile.PL line 30.

Change History (8)

comment:1 Changed 14 years ago by Dominic Hargreaves

Description: modified (diff)

comment:2 Changed 14 years ago by Dominic Hargreaves

Owner: changed from Nobody to Dominic Hargreaves
Status: newassigned

Correspondence on this ticket to the reporter should be on RT.

comment:3 Changed 14 years ago by Dominic Hargreaves

(In [1116]) Ensure that all modules we ship are versioned. (references #232)

comment:4 Changed 14 years ago by bob

i get this too Creating new 'Build' script for 'OpenGuides' version '0.61' Can't locate OpenGuides/Build?.pm in @INC (@INC contains: _build/lib /opt/csw/lib/perl/5.8.8 /opt/csw/share/perl/5.8.8 /opt/csw/lib/perl/site_perl /opt/csw/share/perl/site_perl /opt/csw/lib/perl/csw /opt/csw/share/perl/csw .) at Makefile.PL line 30. Warning: No success on commandMakefile.PL

DOM/OpenGuides-0.61.tar.gz /opt/csw/bin/perl Makefile.PL -- NOT OK

Failed during this command:

DOM/OpenGuides-0.61.tar.gz : writemakefile NO '/opt/csw/bin/perl Makefile.PL' returned status 512

comment:5 Changed 14 years ago by bob

okay. _build/lib doesnt exist and certainly doesnt have any contents. if you edit Makefile.pl line 28 to say <code> use lib 'lib'; </code>

you can get a Makefile. At which point i bet it will work in cpan.

I wonder if other people cant see this because they have Openguides installed already so @INC already contains OpenGuides::Build and OpenGuides::Config

this may of course be a bug in Module::Build or CPAN. not copying anythign to _build/lib

comment:6 Changed 14 years ago by bob

if OpenGuides is already installed you dont get an error.

comment:7 Changed 14 years ago by mstevens

I'm also seeing this.

Creating new 'Build' script for 'OpenGuides' version '0.61' Can't locate OpenGuides/Build?.pm in @INC (@INC contains: _build/lib /usr/local/perl-5.10.0/lib/5.10.0/x86_64-linux /usr/local/perl-5.10.0/lib/5.10.0 /usr/local/perl-5.10.0/lib/site_perl/5.10.0/x86_64-linux /usr/local/perl-5.10.0/lib/site_perl/5.10.0 .) at Makefile.PL line 30. Warning: No success on commandMakefile.PL INSTALLDIRS=site

DOM/OpenGuides-0.61.tar.gz /usr/local/perl-5.10.0/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK

comment:8 Changed 13 years ago by Dominic Hargreaves

Resolution: worksforme
Status: assignedclosed

Can't reproduce this with newer versions of CPAN.pm/perl.

Note: See TracTickets for help on using tickets.