Opened 14 years ago

Closed 12 years ago

#204 closed defect (worksforme)

Nodes can be created with no content.

Reported by: Kake Owned by: Nobody
Priority: normal Milestone:
Component: openguides Version: svn
Severity: normal Keywords: hackfestsummer2007-reviewed
Cc:

Description

If you create a new page, and don't give it any content, then OpenGuides gets very confused about whether it exists or not.

To recreate: click "Create New Page", add some data other than content, save the page, and you'll be bounced to a "we don't currently have a page called X"

Change History (7)

comment:1 Changed 14 years ago by Dominic Hargreaves

Owner: changed from Dominic Hargreaves to Nobody

comment:2 Changed 14 years ago by Kake

Owner: changed from Nobody to Kake

comment:3 Changed 14 years ago by Kake

I'm fixing half of this as part of #193 (i.e. proper detection of whether a node has data or not), but we should also do something on the UI side to stop people creating nodes with neither content nor metadata.

comment:4 Changed 14 years ago by Kake

Keywords: hackfestsummer2007-reviewed added

comment:5 Changed 14 years ago by Kake

Status: newassigned

comment:6 Changed 13 years ago by kake

Owner: changed from Kake to Nobody
Status: assignednew

comment:7 Changed 12 years ago by Dominic Hargreaves

Resolution: worksforme
Status: newclosed

I can't reproduce this. The node does get created if no content or metadata are supplied.

Note: See TracTickets for help on using tickets.