Changeset 963


Ignore:
Timestamp:
Mar 22, 2007, 9:17:47 PM (15 years ago)
Author:
Earle Martin
Message:

It's not called CGI::Wiki any more.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/lib/OpenGuides/Utils.pm

    r948 r963  
    7272    my $dbtype = $config->dbtype;
    7373
    74     my %cgi_wiki_exts = (
     74    my %wiki_toolkit_exts = (
    7575                          postgres => "Pg",
    7676                          mysql    => "MySQL",
     
    7878                        );
    7979
    80     my $cgi_wiki_module = "Wiki::Toolkit::Store::" . $cgi_wiki_exts{$dbtype};
    81     eval "require $cgi_wiki_module";
    82     croak "Can't 'require' $cgi_wiki_module.\n" if $@;
     80    my $wiki_toolkit_module = "Wiki::Toolkit::Store::" . $wiki_toolkit_exts{$dbtype};
     81    eval "require $wiki_toolkit_module";
     82    croak "Can't 'require' $wiki_toolkit_module.\n" if $@;
    8383
    8484    # Make store.
    85     my $store = $cgi_wiki_module->new(
     85    my $store = $wiki_toolkit_module->new(
    8686        dbname  => $config->dbname,
    8787        dbuser  => $config->dbuser,
Note: See TracChangeset for help on using the changeset viewer.