Opened 13 years ago

Closed 13 years ago

Last modified 7 years ago

#6 closed enhancement (fixed)

Guiness, ciekawostki i rekordy

Reported by: Dominic Hargreaves Owned by: Dominic Hargreaves
Priority: normal Milestone: 0.53
Component: openguides Version:
Severity: normal Keywords:
Cc:

Description

OpenGuides should support mod_perl. Nuff said.

Change History (11)

comment:1 Changed 13 years ago by Dominic Hargreaves

Component: openguides

comment:2 Changed 13 years ago by chris@…

I got OpenGuides running under Apache::Registry (mod_perl 1.x) for http://saintpaul.openguides.org with only a few hiccups.

I changed all of the globals in wiki.cgi/index.cgi to use 'our' instead of 'my'. This is fairly trivial and shouldn't affect anything.

I had to patch CGI.pm to make sure $r was properly initalized during redirect headers. I'm not sure why this was neccessary but it was going undef during a page-edit-redirect request after the page had been saved by OpenGuides and a redirect request was being made. This was less trivial and needs a better investigation as to why it's happening. I haven't had a chance to really dig into the OpenGuides code yet to figure it out.

Other bugs may still be lurking but I haven't seen them or had any reported yet. I'll let people know when I've gotten further than this.

comment:3 Changed 13 years ago by Dominic Hargreaves

Milestone: 0.52

comment:4 Changed 13 years ago by Dominic Hargreaves

Milestone: 0.520.53

comment:5 Changed 13 years ago by Dominic Hargreaves

(In [748]) mod_perl fixes (references #6)

comment:6 Changed 13 years ago by Dominic Hargreaves

[752] has more fixes.

comment:7 Changed 13 years ago by crschmidt@…

The $r object was something I fixed, but I'm not sure I ever got the code back into OpenGuides? The cause was attempting to use CGI::redirect instead of $q = CGI->new(); $q->redirect(); There should have been a mailing list post about it if I ever sent in a patch for the fix...

comment:8 Changed 13 years ago by crschmidt@…

Also, all cases of 'exit 0' need to be removed in the code -- most of them can simply be replaced by return 0, some can simply be removed.

comment:9 Changed 13 years ago by Dominic Hargreaves

Owner: set to Dominic Hargreaves
Status: newassigned

Re 04/06/06 20:15:43: yup, this was #86

comment:10 Changed 13 years ago by Dominic Hargreaves

Resolution: fixed
Status: assignedclosed

I believe this ticket is effectively closed now. If any new mod_perl bugs present themselves, open a new ticket.

comment:11 Changed 7 years ago by marika28

Summary: mod_perl supportGuiness, ciekawostki i rekordy

Zastanawiasz się jakie są granice ludzkich możliwości? Pewnie interesują Cię informacje o zwierzętach. Słyszałeś o popularnej na całym świecie księdze rekordów i chciałbyś zobaczyć przykładowe guiness. Pragniemy serdecznie zaprosić Cię na naszą stronę WWW na której znajdziesz informacje związane z księga guinessa rekordy, a więc biciem rekordów Guinnessa! Sprawdź nasze rekordy Guinnessa.

Note: See TracTickets for help on using tickets.